<!DOCTYPE html>
<html lang="en-US" prefix="og: http://ogp.me/ns#">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="profile" href="https://gmpg.org/xfn/11">
<link rel="pingback" href="https://vrzone.com/core/xmlrpc.php">
<title>Huawei P40 Pro+ 5G Review: Petal Search Supercharges The App-xperience</title>

<meta property="og:type" content="article" />
<meta property="og:title" content="Huawei P40 Pro+ 5G Review: Petal Search Supercharges The App-xperience" />
<meta property="og:description" content="The recently announced Huawei P40 Pro+ is now available in Singapore! We recently had a chance to play around with it and we believe that despite Huawei’s lack of Google services, the P40+ Pro is" />
<meta property="og:image" content="https://vrzone.com/wp-content/uploads/2020/06/photo6305588487264512678.jpg" />
<meta property="og:url" content="https://vrzone.com/articles/huawei-p40-pro-5g-review-petal-search-supercharges-the-app-xperience/142344.html" />
<meta property="og:site_name" content="" />
<meta property="article:author" content="http://facebook.com/vrzone" />
<meta property="article:published_time" content="2020-06-28T10:00:18+00:00" />
<meta property="article:modified_time" content="2020-06-28T04:21:29+00:00" />
<meta property="og:updated_time" content="2020-06-28T04:21:29+00:00" />


<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:title" content="Huawei P40 Pro+ 5G Review: Petal Search Supercharges The App-xperience">
<meta name="twitter:description" content="The recently announced Huawei P40 Pro+ is now available in Singapore! We recently had a chance to play around with it and we believe that despite Huawei’s lack of Google services, the P40+ Pro is">
<meta name="twitter:image" content="https://vrzone.com/wp-content/uploads/2020/06/photo6305588487264512678.jpg">
<meta name="twitter:creator" content="@vrzone">


<link rel="canonical" href="https://vrzone.com/articles/huawei-p40-pro-5g-review-petal-search-supercharges-the-app-xperience/142344.html" />
<link rel="publisher" href="https://plus.google.com/vrzone" />

<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title=" &raquo; Feed" href="https://vrzone.com/feed" />
<link rel="alternate" type="application/rss+xml" title=" &raquo; Comments Feed" href="https://vrzone.com/comments/feed" />
<link rel="alternate" type="application/rss+xml" title=" &raquo; Huawei P40 Pro+ 5G Review: Petal Search Supercharges The App-xperience Comments Feed" href="https://vrzone.com/articles/huawei-p40-pro-5g-review-petal-search-supercharges-the-app-xperience/142344.html/feed" />

<script type="text/javascript" data-cfasync="false">
		var disableStr = 'ga-disable-UA-5901053-26';

	/* Function to detect opted out users */
	function __gaTrackerIsOptedOut() {
		return document.cookie.indexOf(disableStr + '=true') > -1;
	}

	/* Disable tracking if the opt-out cookie exists. */
	if ( __gaTrackerIsOptedOut() ) {
		window[disableStr] = true;
	}

	/* Opt-out function */
	function __gaTrackerOptout() {
	  document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
	  window[disableStr] = true;
	}
		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
		(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
		m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
	})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

	__gaTracker('create', 'UA-5901053-26', 'auto');
	__gaTracker('set', 'forceSSL', true);
	__gaTracker('send','pageview');
</script>

<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11.2.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11.2.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/vrzone.com\/core\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.1.1"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wp-block-library-css' href='https://vrzone.com/core/wp-includes/css/dist/block-library/style.min.css?ver=5.1.1' type='text/css' media='all' />
<link rel='stylesheet' id='digg-digg-css' href='https://vrzone.com/wp-content/plugins/digg-digg/css/diggdigg-style.css?ver=5.3.6a' type='text/css' media='screen' />
<link rel='stylesheet' id='mashsb-styles-css' href='https://vrzone.com/wp-content/plugins/mashsharer/assets/css/mashsb.min.css?ver=3.4.7' type='text/css' media='all' />
<style id='mashsb-styles-inline-css' type='text/css'>
.mashsb-count {color:#cccccc;}@media only screen and (min-width:568px){.mashsb-buttons a {min-width: 177px;}}
</style>
<link rel='stylesheet' id='responsive-lightbox-swipebox-css' href='https://vrzone.com/wp-content/plugins/responsive-lightbox/assets/swipebox/css/swipebox.min.css?ver=1.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp_review-style-css' href='https://vrzone.com/wp-content/plugins/wp-review/assets/css/wp-review.css?ver=4.0.16' type='text/css' media='all' />
<link rel='stylesheet' id='wp-pagenavi-css' href='https://vrzone.com/wp-content/plugins/wp-pagenavi/pagenavi-css.css?ver=2.70' type='text/css' media='all' />
<link rel='stylesheet' id='mm_icomoon-css' href='https://vrzone.com/wp-content/plugins/mega_main_menu/framework/src/css/icomoon.css?ver=2.1.2' type='text/css' media='all' />
<link rel='stylesheet' id='mmm_mega_main_menu-css' href='https://vrzone.com/wp-content/plugins/mega_main_menu/src/css/cache.skin.css?ver=5.1.1' type='text/css' media='all' />
<link rel='stylesheet' id='parent-style-css' href='https://vrzone.com/wp-content/themes/vmag-pro/style.css?ver=5.1.1' type='text/css' media='all' />
<link rel='stylesheet' id='vmag-pro-google-fonts-css' href='//fonts.googleapis.com/css?family=Open+Sans%3A400%2C600%2C700%2C400italic%2C300%7CRoboto%3A400%2C500%2C700%2C300%2C400italic&#038;ver=5.1.1' type='text/css' media='all' />
<link rel='stylesheet' id='lightslider-style-css' href='https://vrzone.com/wp-content/themes/vmag-pro/assets/library/lightslider/lightslider.css?ver=1.1.5' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-style-css' href='https://vrzone.com/wp-content/themes/vmag-pro/assets/library/font-awesome/css/font-awesome.css?ver=4.5.0' type='text/css' media='all' />
<link rel='stylesheet' id='animate-css-css' href='https://vrzone.com/wp-content/themes/vmag-pro/assets/css/animate.css?ver=3.5.1' type='text/css' media='all' />
<link rel='stylesheet' id='prettyPhoto-style-css' href='https://vrzone.com/wp-content/themes/vmag-pro/assets/css/prettyPhoto.css?ver=3.1.6' type='text/css' media='all' />
<link rel='stylesheet' id='mCustomScrollbar-style-css' href='https://vrzone.com/wp-content/themes/vmag-pro/assets/library/scrollbar/jquery.mCustomScrollbar.min.css?ver=3.1.5' type='text/css' media='all' />
<link rel='stylesheet' id='vmag-pro-style-css' href='https://vrzone.com/wp-content/themes/vmag-pro-vrzone/style.css?ver=1.0.13' type='text/css' media='all' />
<style id='vmag-pro-style-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='vmag-pro-responsive-style-css' href='https://vrzone.com/wp-content/themes/vmag-pro/assets/css/responsive.css?ver=1.0.13' type='text/css' media='all' />
<link rel='stylesheet' id='tablepress-default-css' href='https://vrzone.com/wp-content/plugins/tablepress/css/default.min.css?ver=1.9' type='text/css' media='all' />
<link rel='stylesheet' id='upprev-css-css' href='https://vrzone.com/wp-content/plugins/upprev/styles/upprev.css?ver=3.4.0.1' type='text/css' media='all' />
<link rel='stylesheet' id='vmag-pro-vrzone-responsive-style-css' href='https://vrzone.com/wp-content/themes/vmag-pro-vrzone/responsive.css?ver=5.1.1' type='text/css' media='all' />
<script type="text/javascript">
var iworks_upprev = { animation: 'flyout', position: 'right', offset_percent: 75, offset_element: '#comments', css_width: 360, css_side: 5, compare: 'simple', url_new_window: 0, ga_track_views: 1, ga_track_clicks: 1, ga_opt_noninteraction: 1, title: 'Huawei P40 Pro+ 5G Review: Petal Search Supercharges The App-xperience' };
</script>
<script type='text/javascript' src='https://vrzone.com/core/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://vrzone.com/core/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var monsterinsights_frontend = {"js_events_tracking":"true","is_debug_mode":"false","download_extensions":"doc,exe,js,pdf,ppt,tgz,zip,xls","inbound_paths":"","home_url":"https:\/\/vrzone.com","track_download_as":"event","internal_label":"int","hash_tracking":"false"};
/* ]]> */
</script>
<script type='text/javascript' src='https://vrzone.com/wp-content/plugins/google-analytics-for-wordpress/assets/js/frontend.min.js?ver=6.2.6'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var mashsb = {"shares":"78","round_shares":"1","animate_shares":"0","dynamic_buttons":"0","share_url":"https:\/\/vrzone.com\/articles\/huawei-p40-pro-5g-review-petal-search-supercharges-the-app-xperience\/142344.html","title":"Huawei+P40+Pro%2B+5G+Review%3A+Petal+Search+Supercharges+The+App-xperience","image":"https:\/\/vrzone.com\/wp-content\/uploads\/2020\/06\/photo6305588487264512678.jpg","desc":"The recently announced Huawei P40 Pro+ is now available in Singapore! We recently had a chance to play around with it and we believe that despite Huawei\u2019s lack of Google services, the P40+ Pro is \u2026","hashtag":"","subscribe":"link","subscribe_url":"https:\/\/mailchi.mp\/9cd0363213a8\/vrz","activestatus":"1","singular":"1","twitter_popup":"1","refresh":"0"};
/* ]]> */
</script>
<script type='text/javascript' src='https://vrzone.com/wp-content/plugins/mashsharer/assets/js/mashsb.min.js?ver=3.4.7'></script>
<script type='text/javascript' src='https://vrzone.com/wp-content/plugins/responsive-lightbox/assets/swipebox/js/jquery.swipebox.min.js?ver=1.7.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var rlArgs = {"script":"swipebox","selector":"lightbox","customEvents":"","activeGalleries":"1","animation":"1","hideCloseButtonOnMobile":"0","removeBarsOnMobile":"0","hideBars":"1","hideBarsDelay":"5000","videoMaxWidth":"1080","useSVG":"1","loopAtEnd":"0","woocommerce_gallery":"0"};
/* ]]> */
</script>
<script type='text/javascript' src='https://vrzone.com/wp-content/plugins/responsive-lightbox/js/front.js?ver=1.7.2'></script>
<script type='text/javascript' src='https://vrzone.com/wp-content/plugins/mega_main_menu/src/js/frontend.js?ver=5.1.1'></script>
<script type='text/javascript' src='https://vrzone.com/wp-content/plugins/usp-pro/js/usp-pro.js?ver=2.5'></script>
<script type='text/javascript' src='https://vrzone.com/wp-content/plugins/upprev/scripts/upprev.js?ver=3.4.0.1'></script>
<link rel='https://api.w.org/' href='https://vrzone.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://vrzone.com/core/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://vrzone.com/core/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 5.1.1" />
<link rel='shortlink' href='https://vrzone.com/?p=142344' />
<link rel="alternate" type="application/json+oembed" href="https://vrzone.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fvrzone.com%2Farticles%2Fhuawei-p40-pro-5g-review-petal-search-supercharges-the-app-xperience%2F142344.html" />
<link rel="alternate" type="text/xml+oembed" href="https://vrzone.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fvrzone.com%2Farticles%2Fhuawei-p40-pro-5g-review-petal-search-supercharges-the-app-xperience%2F142344.html&#038;format=xml" />
<meta property="fb:pages" content="7320808009" />
<meta property="ia:markup_url" content="https://vrzone.com/articles/huawei-p40-pro-5g-review-petal-search-supercharges-the-app-xperience/142344.html?ia_markup=1" />
<meta property="fb:pages" content="7320808009" /><script type='text/javascript' data-cfasync='false'>var _mmunch = {'front': false, 'page': false, 'post': false, 'category': false, 'author': false, 'search': false, 'attachment': false, 'tag': false};_mmunch['post'] = true; _mmunch['postData'] = {"ID":142344,"post_name":"huawei-p40-pro-5g-review-petal-search-supercharges-the-app-xperience","post_title":"Huawei P40 Pro+ 5G Review: Petal Search Supercharges The App-xperience","post_type":"post","post_author":"308","post_status":"publish"}; _mmunch['postCategories'] = [{"term_id":17174,"name":"Huawei","slug":"huawei","term_group":0,"term_taxonomy_id":17175,"taxonomy":"category","description":"","parent":16797,"count":43,"filter":"raw","cat_ID":17174,"category_count":43,"category_description":"","cat_name":"Huawei","category_nicename":"huawei","category_parent":16797},{"term_id":24,"name":"News","slug":"news","term_group":0,"term_taxonomy_id":359,"taxonomy":"category","description":"","parent":0,"count":25519,"filter":"raw","cat_ID":24,"category_count":25519,"category_description":"","cat_name":"News","category_nicename":"news","category_parent":0},{"term_id":16797,"name":"Personal Technology","slug":"personal-technology","term_group":0,"term_taxonomy_id":16798,"taxonomy":"category","description":"From smartphones to notebooks and wearables. Its all about the gear you want","parent":0,"count":408,"filter":"raw","cat_ID":16797,"category_count":408,"category_description":"From smartphones to notebooks and wearables. Its all about the gear you want","cat_name":"Personal Technology","category_nicename":"personal-technology","category_parent":0},{"term_id":213,"name":"Smartphones","slug":"smartphones","term_group":0,"term_taxonomy_id":213,"taxonomy":"category","description":"","parent":16797,"count":4892,"filter":"raw","cat_ID":213,"category_count":4892,"category_description":"","cat_name":"Smartphones","category_nicename":"smartphones","category_parent":16797}]; _mmunch['postTags'] = false; _mmunch['postAuthor'] = {"name":"","ID":""};</script><script data-cfasync="false" src="//a.mailmunch.co/app/v1/site.js" id="mailmunch-script" data-plugin="mc_mm" data-mailmunch-site-id="214450" async></script><link href="https://vrzone.com/" rel="prerender prefetch" />
<style type="text/css">.proper-widget li {
  clear: both;
  margin: 0 0 0.5em;
  zoom: 1;
}
.proper-widget li:before,
.proper-widget li:after {
  content: "";
  display: table;
}
.proper-widget li:after {
  clear: both;
}
.proper-widget .proper-date {
  font-size: 0.9em;
  font-style: italic;
}
.proper-authors-widget li .alignleft {
  margin: 0 1.5em 0.2em 0;
}
.proper-comments-widget li {
  margin: 0 0 2.5em;
}
.proper-comments-widget li img.avatar {
  float: left;
  margin: 0 1.5em 0.2em 0;
}
.proper-comments-widget li p.proper-comment-header {
  font-size: 0.9em;
  line-height: 1.4em;
  margin-bottom: 1em;
  padding: 0;
}
.proper-embed-widget embed,
.proper-embed-widget iframe,
.proper-embed-widget object,
.proper-embed-widget video {
  max-width: 100% !important;
}
.proper-linked-image-widget li img {
  display: block;
  margin: 1em auto;
  max-width: 100%;
  height: auto !important;
}
.proper-links-widget li img {
  max-width: 100%;
  float: left;
  margin: 0 1.2em 0.2em 0;
}
.proper-posts-widget a.proper-headline-link {
  font-weight: bold;
}
.proper-posts-widget img.alignleft,
.proper-posts-widget img.alignright {
  max-width: 50%;
}
.proper-posts-widget img.aligncenter {
  max-width: 100%;
}
</style><!--[if IE 7]>
<link rel="stylesheet" href="https://vrzone.com/wp-content/plugins/wp-review/assets/css/wp-review-ie7.css">
<![endif]-->
<link href='//fonts.googleapis.com/css?family=Open+Sans:|Roboto:&subset=latin,cyrillic-ext,greek-ext,greek,vietnamese,latin-ext,cyrillic,khmer,devanagari,arabic,hebrew,telugu' rel='stylesheet' type='text/css'>
<link rel="icon" href="https://vrzone.com/wp-content/uploads/2018/01/cropped-cropped-vrzone-favicon-1-2-32x32.png" sizes="32x32" />
<link rel="icon" href="https://vrzone.com/wp-content/uploads/2018/01/cropped-cropped-vrzone-favicon-1-2-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://vrzone.com/wp-content/uploads/2018/01/cropped-cropped-vrzone-favicon-1-2-180x180.png" />
<meta name="msapplication-TileImage" content="https://vrzone.com/wp-content/uploads/2018/01/cropped-cropped-vrzone-favicon-1-2-270x270.png" />
<style type="text/css" id="wp-custom-css">
			/*
You can add your own CSS here.

Click the help icon above to learn more.
*/		</style>
<style type="text/css">
#upprev_box{bottom:50px;width:360px;right:5px;display:block;right:-415px;display:block;}
 </style>
</head>
<body class="post-template-default single single-post postid-142344 single-format-standard wp-custom-logo mmm mega_main_menu-2-1-2 group-blog fullwidth_layout right-sidebar vmag-archive-layout3">
<div id="page" class="site">
<div class="vmag-newsticker-wrapper header-layout2">
<div class="vmag-container default-layout ticker-control-default"> <div class="vmag-ticker-caption">
<span>Recent News</span>
</div>
<ul id="vmag-news-ticker" class="cS-hidden"> <li>
<div class="single-news"><a href="https://vrzone.com/articles/huawei-p40-pro-5g-review-petal-search-supercharges-the-app-xperience/142344.html">Huawei P40 Pro+ 5G Review: Petal Search Supercharges The App-xperience</a></div>
</li>
<li>
<div class="single-news"><a href="https://vrzone.com/articles/apple-adds-options-for-16-inch-macbook-pro-mac-pro-ahead-of-wwdc-2020/142317.html">Apple Adds Options For 16-inch MacBook Pro, Mac Pro Ahead of WWDC 2020</a></div>
</li>
<li>
<div class="single-news"><a href="https://vrzone.com/articles/adobe-photoshop-camera-review-free-app-with-premium-quality/142271.html">Adobe Photoshop Camera Review: Free App With Premium Quality</a></div>
</li>
<li>
<div class="single-news"><a href="https://vrzone.com/articles/sudio-ett-review-true-wireless-anc-airpods-pro-killer-on-paper/142260.html">Sudio ETT Review: True Wireless, ANC AirPods Pro Killer… On Paper</a></div>
</li>
<li>
<div class="single-news"><a href="https://vrzone.com/articles/new-sony-zv-1-compact-4k-video-camera-packs-hot-shoe-portrait-mode/142234.html">New Sony ZV-1 Compact 4K Video Camera Packs Hot Shoe &#038; Portrait Mode</a></div>
</li>
</ui></div></div>
<div class="vmag-top-header header-layout2 clearfix">
<div class="vmag-container">
<div class="vmag-current-date">Sunday, June 28, 2020</div>
<nav id="top-site-navigation" class="top-navigation" role="navigation">
<div class="menu-categories-container"><ul id="top-menu" class="menu vmag_pro_mega_menu"><li id="menu-item-124888" class="menu-item menu-item-type-taxonomy menu-item-object-category page_item page-item-124888 no-mega-menu"><a href="https://vrzone.com/articles/category/gaming">Gaming</a></li>
<li id="menu-item-126399" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent page_item page-item-126399 no-mega-menu"><a href="https://vrzone.com/articles/category/personal-technology">Personal Technology</a></li>
<li id="menu-item-126401" class="menu-item menu-item-type-taxonomy menu-item-object-category page_item page-item-126401 no-mega-menu"><a href="https://vrzone.com/articles/category/smart-living">Smart Living</a></li>
<li id="menu-item-126402" class="menu-item menu-item-type-taxonomy menu-item-object-category page_item page-item-126402 no-mega-menu"><a href="https://vrzone.com/articles/category/motoring">Motoring</a></li>
<li id="menu-item-126403" class="menu-item menu-item-type-taxonomy menu-item-object-category page_item page-item-126403 no-mega-menu"><a href="https://vrzone.com/articles/category/virtual-reality-augmented-reality">Virtual Reality/Augmented Reality</a></li>
</ul></div> </nav>
</div>
</div>
<header id="masthead" class="site-header header-layout2" role="banner">
<div class="logo-ad-wrapper clearfix">
<div class="vmag-container">
<div class="site-branding">
<a href="https://vrzone.com/" class="custom-logo-link" rel="home" itemprop="url"><img width="539" height="90" src="https://vrzone.com/wp-content/uploads/2017/04/cropped-vrzone-black-2.png" class="custom-logo" alt="" itemprop="logo" srcset="https://vrzone.com/wp-content/uploads/2017/04/cropped-vrzone-black-2.png 539w, https://vrzone.com/wp-content/uploads/2017/04/cropped-vrzone-black-2-300x50.png 300w, https://vrzone.com/wp-content/uploads/2017/04/cropped-vrzone-black-2-534x90.png 534w, https://vrzone.com/wp-content/uploads/2017/04/cropped-vrzone-black-2-535x90.png 535w" sizes="(max-width: 539px) 100vw, 539px" /></a>
<div class="site-title-wrapper">
<p class="site-title"><a href="https://vrzone.com/" rel="home"></a></p>
<p class="site-description">Prosumer Reviews for 22 million Enthusiasts</p>
</div>
</div>
<div class="header-ad-wrapper">
<section id="adwidget_htmlwidget-16" class="widget AdWidget_HTMLWidget"><div style='text-align: center;'><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:inline-block;width:728px;height:90px" data-ad-client="ca-pub-5519572716512296" data-ad-slot="6917120499"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div></section> </div>
</div>
</div>
<nav id="site-navigation" class="main-navigation clearfix" role="navigation">
<div class="vmag-container">
<div class="nav-wrapper">
<div class="nav-toggle hide">
<span> </span>
<span> </span>
<span> </span>
</div>
<div class="mobile-logo">
<a href="https://vrzone.com/" class="custom-logo-link" rel="home" itemprop="url"><img width="539" height="90" src="https://vrzone.com/wp-content/uploads/2017/04/cropped-vrzone-black-2.png" class="custom-logo" alt="" itemprop="logo" srcset="https://vrzone.com/wp-content/uploads/2017/04/cropped-vrzone-black-2.png 539w, https://vrzone.com/wp-content/uploads/2017/04/cropped-vrzone-black-2-300x50.png 300w, https://vrzone.com/wp-content/uploads/2017/04/cropped-vrzone-black-2-534x90.png 534w, https://vrzone.com/wp-content/uploads/2017/04/cropped-vrzone-black-2-535x90.png 535w" sizes="(max-width: 539px) 100vw, 539px" /></a> </div>
<div class="index-icon">
<a href="https://vrzone.com/"><i class="fa fa-home"></i></a>
</div>
<div class="menu-channels-container"><ul id="primary-menu" class="menu vmag_pro_mega_menu"><li id="menu-item-81455" class="menu-item menu-item-type-custom menu-item-object-custom page_item page-item-81455 no-mega-menu"><a target="_blank" href="http://sgcafe.com">SGCafe</a></li>
<li id="menu-item-81449" class="menu-item menu-item-type-custom menu-item-object-custom page_item page-item-81449 no-mega-menu"><a target="_blank" href="http://forums.vrzone.com">Forums</a></li>
<li id="menu-item-126520" class="menu-item menu-item-type-custom menu-item-object-custom page_item page-item-126520 no-mega-menu"><a href="https://vrzone.com/wp-content/uploads/2019/07/VR-Zone-Rate-Card-2019-1.pdf">Advertise</a></li>
</ul></div> </div>
<div class="icons-wrapper clearfix">
<span class="icon-search vmag-search-in-primary"></span>
</div>
<div class="vmag-search-form-primary"><form role="search" method="get" class="search-form" action="https://vrzone.com/">
<label>
<span class="screen-reader-text">Search for:</span>
<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
</label>
<input type="submit" class="search-submit" value="Search" />
</form></div>
</div>
</nav>
</header>
<div id="content" class="site-content">
<div class="vmag-container">
<div class="vmag-bread-home" id="vmag-breadcrumbs" xmlns:v="http://rdf.data-vocabulary.org/#"><span typeof="v:Breadcrumb"><a rel="v:url" property="v:title" href="https://vrzone.com/">Home</a></span> &gt <span typeof="v:Breadcrumb"><a rel="v:url" property="v:title" href="https://vrzone.com/articles/category/personal-technology">Personal Technology</a></span> &gt <span typeof="v:Breadcrumb"><a rel="v:url" property="v:title" href="https://vrzone.com/articles/category/personal-technology/huawei">Huawei</a></span> &gt <span class="current">Huawei P40 Pro+ 5G Review: Petal Search Supercharges The App-xperience</span></div><div class="single-layout2-header">
<div class="entry-thumb"><img width="1200" height="630" src="https://vrzone.com/wp-content/uploads/2020/06/photo6305588487264512678-1200x630.jpg" class="attachment-vmag-pro-single-large size-vmag-pro-single-large wp-post-image" alt="" /></div> <div class="layout2-header-info-wrapper">
<span class="cat-links"><a href="https://vrzone.com/articles/category/personal-technology/huawei" class="cat-17174" rel="category tag">Huawei</a><a href="https://vrzone.com/articles/category/news" class="cat-24" rel="category tag">News</a><a href="https://vrzone.com/articles/category/personal-technology" class="cat-16797" rel="category tag">Personal Technology</a><a href="https://vrzone.com/articles/category/personal-technology/smartphones" class="cat-213" rel="category tag">Smartphones</a></span> <header class="entry-header">
<h1 class="entry-title">Huawei P40 Pro+ 5G Review: Petal Search Supercharges The App-xperience</h1>
</header>
<div class="entry-meta clearfix">
<span class="post-author"><span class="author vcard"><a class="url fn n" href="https://vrzone.com/articles/author/teamvr">TeamVR</a></span></span><span class="posted-on"> <a href="https://vrzone.com/articles/huawei-p40-pro-5g-review-petal-search-supercharges-the-app-xperience/142344.html" rel="bookmark"><time class="entry-date published" datetime="2020-06-28T10:00:18+08:00">June 28, 2020</time><time class="updated" datetime="2020-06-28T04:21:29+08:00">June 28, 2020</time></a></span> </div>
</div>
</div>
<div id="primary" class="content-area vmag-content">
<main id="main" class="site-main" role="main">
<article id="post-142344" class="post-142344 post type-post status-publish format-standard has-post-thumbnail hentry category-huawei category-news category-personal-technology category-smartphones">
<div class="entry-content">
<aside class="mashsb-container mashsb-main mashsb-stretched"><div class="mashsb-box"><div class="mashsb-count mash-large" style="float:left;"><div class="counts mashsbcount">78</div><span class="mashsb-sharetext">SHARES</span></div><div class="mashsb-buttons"><a class="mashicon-facebook mash-large mash-center mashsb-noshadow" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fvrzone.com%2Farticles%2Fhuawei-p40-pro-5g-review-petal-search-supercharges-the-app-xperience%2F142344.html" target="_blank" rel="nofollow"><span class="icon"></span><span class="text">Share</span></a><a class="mashicon-twitter mash-large mash-center mashsb-noshadow" href="https://twitter.com/intent/tweet?text=Huawei%20P40%20Pro%2B%205G%20Review%3A%20Petal%20Search%20Supercharges%20The%20App-xperience&url=https://vrzone.com/articles/huawei-p40-pro-5g-review-petal-search-supercharges-the-app-xperience/142344.html" target="_blank" rel="nofollow"><span class="icon"></span><span class="text">Tweet</span></a><a class="mashicon-subscribe mash-large mash-center mashsb-noshadow" href="#" target="_blank" rel="nofollow"><span class="icon"></span><span class="text">Newsletter</span></a><div class="onoffswitch2 mash-large mashsb-noshadow" style="display:none;"></div></div>
</div>
<div style="clear:both;"></div></aside>
<div class='mailmunch-forms-before-post' style='display: none !important;'></div><a id="dd_start"></a>
<p>The recently announced <a href="https://consumer.huawei.com/sg/phones/p40-pro-plus/?utm_medium=VRZone&amp;utm_source=FB-FB-Video&amp;utm_campaign=SG_P40ProPlus&amp;utm_content=Promo&amp;utm_term=VRZone">Huawei P40 Pro+</a> is now available in Singapore! We recently had a chance to play around with it and we believe that despite Huawei’s lack of Google services, the P40+ Pro is still one of the best Android phones out there and worthy of your attention, especially when it comes to performance and camera technology.</p>
<h2>Performance</h2>
<ul class="wp-block-gallery columns-2 is-cropped"><li class="blocks-gallery-item"><figure><img src="https://vrzone.com/wp-content/uploads/2020/06/photo6312257905755269649-1024x576.jpg" alt="" data-id="142347" data-link="https://vrzone.com/?attachment_id=142347" class="wp-image-142347" srcset="https://vrzone.com/wp-content/uploads/2020/06/photo6312257905755269649-1024x576.jpg 1024w, https://vrzone.com/wp-content/uploads/2020/06/photo6312257905755269649-300x169.jpg 300w, https://vrzone.com/wp-content/uploads/2020/06/photo6312257905755269649-768x432.jpg 768w, https://vrzone.com/wp-content/uploads/2020/06/photo6312257905755269649.jpg 1280w" sizes="(max-width: 1024px) 100vw, 1024px" /></figure></li><li class="blocks-gallery-item"><figure><img src="https://vrzone.com/wp-content/uploads/2020/06/photo6312257905755269648-1-1024x576.jpg" alt="" data-id="142348" data-link="https://vrzone.com/?attachment_id=142348" class="wp-image-142348" srcset="https://vrzone.com/wp-content/uploads/2020/06/photo6312257905755269648-1-1024x576.jpg 1024w, https://vrzone.com/wp-content/uploads/2020/06/photo6312257905755269648-1-300x169.jpg 300w, https://vrzone.com/wp-content/uploads/2020/06/photo6312257905755269648-1-768x432.jpg 768w, https://vrzone.com/wp-content/uploads/2020/06/photo6312257905755269648-1.jpg 1280w" sizes="(max-width: 1024px) 100vw, 1024px" /></figure></li></ul>
<p>As Huawei’s new flagship phone, the P40 Pro+ comes with the latest Kirin 990 5G chipset, making it one of the first 5G phones in Singapore. Although Singapore does not yet have any live 5G networks, it ensures that your phone will be future proof once it arrives.<br></p>
<p>In terms of performance, the Kirin 990 chipset definitely lives up to the competition. Apart from Apple and Samsung, Huawei is the only other phone brand that designs its own chipsets, which means it can ensure vertical integration between its software and hardware to bring better performance and battery life. And compared to Apple and Samsung’s flagships, the P40 Pro+ really does not disappoint. App launches are as snappy, and games and other graphics intensive apps run very smoothly, even on the P40 Pro+’s 90Hz screen.&nbsp;<br></p>
<p>In benchmarks, the Kirin 990 chipset beats Samsung’s Exynos in the Geekbench CPU benchmark, losing only to Apple. In the GPU-intensive 3D Mark Slingshot Extreme, it actually beats Samsung and Apple’s chipsets by quite a large margin, making it one of the faster mobile chipsets around.</p>
<h2><strong>Screen</strong><br></h2>
<figure class="wp-block-image"><img src="https://vrzone.com/wp-content/uploads/2020/06/photo6305588487264512674-1024x682.jpg" alt="" class="wp-image-142350" srcset="https://vrzone.com/wp-content/uploads/2020/06/photo6305588487264512674-1024x682.jpg 1024w, https://vrzone.com/wp-content/uploads/2020/06/photo6305588487264512674-300x200.jpg 300w, https://vrzone.com/wp-content/uploads/2020/06/photo6305588487264512674-768x512.jpg 768w, https://vrzone.com/wp-content/uploads/2020/06/photo6305588487264512674.jpg 1280w" sizes="(max-width: 1024px) 100vw, 1024px" /></figure>
<p>Like most other flagship Android devices in 2020, the P40 Pro+ keeps up with the latest trend of having a high refresh rate screen. The display is a 90Hz OLED display, similar to the OnePlus had in their 7T.&nbsp; It is slightly slower than Samsung’s 120Hz display in the S20 lineup, but to the human eye, at normal distances it is almost indistinguishable.&nbsp;<br></p>
<p>Colours on the display are amazing and eye-popping, as is expected from an OLED display. It also conforms to the latest HDR10 standard, which allows for HDR content to be played back on games and videos that support it.</p>
<h2>Cameras<br></h2>
<figure class="wp-block-image"><img src="https://vrzone.com/wp-content/uploads/2020/06/photo6305588487264512672-1024x682.jpg" alt="" class="wp-image-142351" srcset="https://vrzone.com/wp-content/uploads/2020/06/photo6305588487264512672-1024x682.jpg 1024w, https://vrzone.com/wp-content/uploads/2020/06/photo6305588487264512672-300x200.jpg 300w, https://vrzone.com/wp-content/uploads/2020/06/photo6305588487264512672-768x512.jpg 768w, https://vrzone.com/wp-content/uploads/2020/06/photo6305588487264512672.jpg 1280w" sizes="(max-width: 1024px) 100vw, 1024px" /></figure>
<p>Huawei’s greatest selling point for most of its flagships has been their camera capabilities, and the P40 Pro+ carries on this trend. The P40+ Pro has 4 cameras, a standard 50-megapixel f/1.9 shooter, a 40-megapixel ultrawide, an 8-megapixel 3x zoom, as well as an 8-megapixel camera with a periscope telephoto lens that offers up to 10x optical zoom. The standard and telephoto lenses come with optical image stabilization to improve stability in low light settings. In addition, there is also a 3D Time Of Flight (TOF) sensor that gives depth sensing information, which should aid in faster focusing.</p>
<figure class="wp-block-image"><img src="https://vrzone.com/wp-content/uploads/2020/06/photo6309666202229779321-1024x576.jpg" alt="" class="wp-image-142352" srcset="https://vrzone.com/wp-content/uploads/2020/06/photo6309666202229779321-1024x576.jpg 1024w, https://vrzone.com/wp-content/uploads/2020/06/photo6309666202229779321-300x169.jpg 300w, https://vrzone.com/wp-content/uploads/2020/06/photo6309666202229779321-768x432.jpg 768w, https://vrzone.com/wp-content/uploads/2020/06/photo6309666202229779321.jpg 1280w" sizes="(max-width: 1024px) 100vw, 1024px" /></figure>
<p>Performance of the cameras is similar to what you will find on Huawei’s P40 Pro, with photos sharp and contrasty, and on par with the latest flagships from Apple and Samsung.&nbsp;<br></p>
<p>The 100x periscope lens allows you to zoom in to far away objects optically without cropping, giving it far batter and clearer results compared to cropping photos from any iPhone or even Huawei’s own P40 with 50x zoom.</p>
<ul class="wp-block-gallery columns-3 is-cropped"><li class="blocks-gallery-item"><figure><img src="https://vrzone.com/wp-content/uploads/2020/06/IMG_4086-Large-1024x715.jpg" alt="" data-id="142353" data-link="https://vrzone.com/?attachment_id=142353" class="wp-image-142353" srcset="https://vrzone.com/wp-content/uploads/2020/06/IMG_4086-Large-1024x715.jpg 1024w, https://vrzone.com/wp-content/uploads/2020/06/IMG_4086-Large-300x210.jpg 300w, https://vrzone.com/wp-content/uploads/2020/06/IMG_4086-Large-768x537.jpg 768w, https://vrzone.com/wp-content/uploads/2020/06/IMG_4086-Large-320x224.jpg 320w, https://vrzone.com/wp-content/uploads/2020/06/IMG_4086-Large.jpg 1546w" sizes="(max-width: 1024px) 100vw, 1024px" /></figure></li><li class="blocks-gallery-item"><figure><img src="https://vrzone.com/wp-content/uploads/2020/06/IMG_4087-Large-1024x715.jpg" alt="" data-id="142354" data-link="https://vrzone.com/?attachment_id=142354" class="wp-image-142354" srcset="https://vrzone.com/wp-content/uploads/2020/06/IMG_4087-Large-1024x715.jpg 1024w, https://vrzone.com/wp-content/uploads/2020/06/IMG_4087-Large-300x210.jpg 300w, https://vrzone.com/wp-content/uploads/2020/06/IMG_4087-Large-768x537.jpg 768w, https://vrzone.com/wp-content/uploads/2020/06/IMG_4087-Large-320x224.jpg 320w, https://vrzone.com/wp-content/uploads/2020/06/IMG_4087-Large.jpg 1546w" sizes="(max-width: 1024px) 100vw, 1024px" /></figure></li><li class="blocks-gallery-item"><figure><img src="https://vrzone.com/wp-content/uploads/2020/06/IMG_4088-Large-1024x715.jpg" alt="" data-id="142355" data-link="https://vrzone.com/?attachment_id=142355" class="wp-image-142355" srcset="https://vrzone.com/wp-content/uploads/2020/06/IMG_4088-Large-1024x715.jpg 1024w, https://vrzone.com/wp-content/uploads/2020/06/IMG_4088-Large-300x210.jpg 300w, https://vrzone.com/wp-content/uploads/2020/06/IMG_4088-Large-768x537.jpg 768w, https://vrzone.com/wp-content/uploads/2020/06/IMG_4088-Large-320x224.jpg 320w, https://vrzone.com/wp-content/uploads/2020/06/IMG_4088-Large.jpg 1546w" sizes="(max-width: 1024px) 100vw, 1024px" /></figure></li></ul>
<h2><strong>OS and User Experience</strong></h2>
<figure class="wp-block-image"><img src="https://vrzone.com/wp-content/uploads/2020/06/photo6305588487264512680-1024x682.jpg" alt="" class="wp-image-142356" srcset="https://vrzone.com/wp-content/uploads/2020/06/photo6305588487264512680-1024x682.jpg 1024w, https://vrzone.com/wp-content/uploads/2020/06/photo6305588487264512680-300x200.jpg 300w, https://vrzone.com/wp-content/uploads/2020/06/photo6305588487264512680-768x512.jpg 768w, https://vrzone.com/wp-content/uploads/2020/06/photo6305588487264512680.jpg 1280w" sizes="(max-width: 1024px) 100vw, 1024px" /></figure>
<p>As with all Huawei phone reviews, we always need to address the elephant in the room. Google may have pulled support for Google Mobile Services (GMS) from the latest Huawei phones, but the P40 Pro+ still comes with the latest version of Android. Huawei has done a pretty good job of substituting GMS with its own Huawei Mobile Services (HMS), and even includes its own app store called the Huawei AppGallery.</p><div class='mailmunch-forms-in-post-middle' style='display: none !important;'></div>
<h4><strong>Huawei’s app store: AppGallery</strong></h4>
<figure class="wp-block-image"><img src="https://vrzone.com/wp-content/uploads/2020/06/photo6309666202229779310-1024x576.jpg" alt="" class="wp-image-142357" srcset="https://vrzone.com/wp-content/uploads/2020/06/photo6309666202229779310-1024x576.jpg 1024w, https://vrzone.com/wp-content/uploads/2020/06/photo6309666202229779310-300x169.jpg 300w, https://vrzone.com/wp-content/uploads/2020/06/photo6309666202229779310-768x432.jpg 768w, https://vrzone.com/wp-content/uploads/2020/06/photo6309666202229779310.jpg 1280w" sizes="(max-width: 1024px) 100vw, 1024px" /></figure>
<p>The Huawei AppGallery may still be new and lacking some apps like Facebook or WhatsApp (more on that later), but it has been rapidly expanding its offering in recent weeks, adding support for many popular apps like TikTok and LINE. There are also many apps for local services like Ryde and Foodpanda, online marketplaces like Shopee and Qoo10, and even local banks such as DBS and UOB.</p>
<h4><strong>Getting apps via Phone Clone</strong></h4>
<figure class="wp-block-image"><img src="https://vrzone.com/wp-content/uploads/2020/06/photo6305588487264512670-1024x682.jpg" alt="" class="wp-image-142358" srcset="https://vrzone.com/wp-content/uploads/2020/06/photo6305588487264512670-1024x682.jpg 1024w, https://vrzone.com/wp-content/uploads/2020/06/photo6305588487264512670-300x200.jpg 300w, https://vrzone.com/wp-content/uploads/2020/06/photo6305588487264512670-768x512.jpg 768w, https://vrzone.com/wp-content/uploads/2020/06/photo6305588487264512670.jpg 1280w" sizes="(max-width: 1024px) 100vw, 1024px" /></figure>
<p>You can also use Huawei’s Phone Clone app to transfer data from your old device to the new P40 Pro+, including apps you have installed. If you have apps such as Facebook, Instagram, Twitter, or WhatsApp installed on your old phone, Phone Clone will transfer all these apps automatically to your new phone, along with all your messages and other user data.</p>
<h4><strong>Petal Search: A Gateway to your Favourite Apps</strong></h4>
<figure class="wp-block-image"><img src="https://lh3.googleusercontent.com/WAIA2oz1uJhmSUmkhfxwVSAI3oPbTjzNtXszK1eZLVvLeXMXk0nLZxvadFTYutyILDntYkbuOLSFSSt_4S4qkwjKcaEk0l0p5tvOn-q0ClCYeZ6l7qKy6Q2LiNKdV0XR2mtq_uAb" alt="" /></figure>
<p>If you are starting fresh, you may want to check out the latest Petal Search app from Huawei that is available for download from the AppGallery. Petal Search offers a gateway to Android apps that are available from and outside of AppGallery. It works like a search engine for apps and links you to the various sources that are available to install your desired app. </p>
<figure class="wp-block-image"><img src="https://lh3.googleusercontent.com/8XIhSKzVf_3r5TlGpLsYwkaNlSLSmrhCU0bd-wJzTqe_SoIbDHKsFsZhJEHV94yyDTmG9xKPyvvTc-d8MACd2x5yaL2w7vJed_hFs2oBqREaF6DP9Oy_HvtFVIg1_2546V9_WAIm" alt="" /><figcaption> <br><strong>Petal Search generates a list of APK sources that you can download the app from. If the app is available on AppGallery, it will appear as a top result.</strong> </figcaption></figure>
<p>You’ll have to bear in mind that Petal Search is not an app store, and not all apps are guaranteed to work. Some apps such as YouTube for example, require GMS to function. You can install other popular apps that are not yet available on AppGallery like Netflix, Telegram, Reddit and more via Petal Search.<br></p>
<p>There are also many other workarounds to getting your usual apps on Huawei phones. As an Android phone, the P40 Pro+ allows the sideloading of Android applications, which means you can download the APK file from APK sites and install them directly onto your phone. In anticipation of many power users taking this route, Huawei has even implemented security measures such as running a security check before installing any app. However, as always, do this at your own risk, as sideloaded apps downloaded from non-reputable sources may introduce viruses to your phone.</p>
<figure class="wp-block-image"><img src="https://lh6.googleusercontent.com/lGQHD-3gKhDTA1AsJt6rj-ygy4SN2rpILVe3vSx_mnEHW-zqt0vwN6yGMn9J8_LIEO01dBGFegn31KVWL6525rZlpw8noOWw8TxOtkM9pnN7NYVAdRL_eLTxOKJ0MI0972vIm30o" alt="" /><figcaption><br></figcaption></figure>
<p>As an ultimate fallback, most online platforms also offer a web browser-based experience which you can get by navigating to their website. For ease of use, you can choose to add these web apps to your homescreen for faster and easier access.</p>
<h2><strong>Concluding Thoughts</strong><br></h2>
<figure class="wp-block-image"><img src="https://lh6.googleusercontent.com/Q00ZyzaTL1kgSnBcRxUxfmttb7oQidqoqH5utBkXDxNMpH5xD6wHkTq2pxhjNoqRXxPGV0Thp-vW0eNQle8GzvhqG0n-TcQe06wXr4GAl7577N4xQ4njnnizEc2AGm3QYnBPuyqi" alt="" /></figure>
<p>With the P40 Pro+, Huawei has once again delivered a top tier flagship device that can compete with the best flagships out there. The vertical integration it gets from building its own hardware and software has allowed it to outperform competitors in some benchmarks, and its camera’s performance is still second to none.&nbsp;<br></p>
<p>The main concern for many buyers of the phone will definitely be the lack of GMS. To their credit, Huawei has done an excellent job in trying to mitigate this issue, building their own Huawei Mobile Services and making it easier for users to get their favourite app. What you get from the P40 Pro+ is definitely a fully functional phone with an experience not too far different from other flagship phones. And as Huawei continues to improve HMS, we certainly hope that the user experience continues to get closer and closer to the mainstream Android experience.<br>The Huawei P40 Pro+ costs 1898SGD and is now available at all local telecommunications operators such as M1, Singtel and Starhub; Huawei Concept Stores, Huawei online official stores in <a href="https://www.lazada.sg/shop/huawei-flagship-store/">Lazada</a> and <a href="https://shopee.sg/sghuawei">Shopee </a>as well as authorised retailers including Best Denki, Challenger, COURTS and Harvey Norman. <a href="https://consumer.huawei.com/sg/phones/p40-pro-plus/?utm_medium=VRZone&amp;utm_source=FB-FB-Video&amp;utm_campaign=SG_P40ProPlus&amp;utm_content=Promo&amp;utm_term=VRZone">Click here for more details.</a></p>
<div class='dd_outer'><div class='dd_inner'><div id='dd_ajax_float'><div class='dd_button_v'><script src="//connect.facebook.net/en_US/all.js#xfbml=1"></script><fb:like href="https://vrzone.com/articles/huawei-p40-pro-5g-review-petal-search-supercharges-the-app-xperience/142344.html" send="false" show_faces="false" layout="box_count" width="50"></fb:like></div><div style='clear:left'></div><div class='dd_button_v'><div class='dd-google1-ajax-load dd-google1-142344'></div><g:plusone size='tall' href='https://vrzone.com/articles/huawei-p40-pro-5g-review-petal-search-supercharges-the-app-xperience/142344.html'></g:plusone></div><div style='clear:left'></div></div></div></div><script type="text/javascript">var dd_offset_from_content = 100;var dd_top_offset_from_content = 0;var dd_override_start_anchor_id = "";var dd_override_top_offset = "0";</script><script type="text/javascript" src="https://vrzone.com/wp-content/plugins/digg-digg//js/diggdigg-floating-bar.js?ver=5.3.6a"></script><script type="text/javascript"> jQuery(document).ready(function($) { window.setTimeout('loadGoogle1_142344()',1000); }); </script><script type="text/javascript"> function loadGoogle1_142344(){ jQuery(document).ready(function($) { $('.dd-google1-142344').remove();$.getScript('https://apis.google.com/js/plusone.js'); }); }</script></p><div class='mailmunch-forms-after-post' style='display: none !important;'></div><div data-widget="plista_widget_belowArticle"></div>
<script type="text/javascript">
(function(c){var g,s='script',w=window,n=c.name||'PLISTA';if(!w[n]){w[n]=c;g=w.document.getElementsByTagName(s)[0];s=w.document.createElement(s);s.async=true;s.type='text/javascript';s.src=(w.location.protocol==='https:'?'https:':'http:')+'//static'+(c.origin?'-'+c.origin:'')+'.plista.com/async'+(c.name?'/'+c.name:'')+'.js';g.parentNode.insertBefore(s,g);}
}({
    "publickey": "8834d7cfa4a4688da1ea5838",
	"item": {"objectid":142344,"title":"Huawei P40 Pro+ 5G Review: Petal Search Supercharges The App-xperience","text":"\nThe recently announced Huawei P40 Pro+ is now available in Singapore! We recently had a chance to play around with it and we believe that despite Huawei\u2019s lack of Google services, the P40+ Pro is still one of the best Android phones out there and worth","url":"https:\/\/vrzone.com\/articles\/huawei-p40-pro-5g-review-petal-search-supercharges-the-app-xperience\/142344.html","img":"https:\/\/vrzone.com\/wp-content\/uploads\/2020\/06\/photo6305588487264512678-150x150.jpg","category":"News,Personal Technology","published_at":1593338418,"updated_at":1593318089}
}));
</script>
</div>
<div class="vmag-author-metabox clearfix">
<div class="author-avatar">
<a class="author-image" href="https://vrzone.com/articles/author/teamvr">
<img alt='' src='https://secure.gravatar.com/avatar/61669ed45183e668a84bc3521952c1fa?s=132&#038;d=mm&#038;r=x' srcset='https://secure.gravatar.com/avatar/61669ed45183e668a84bc3521952c1fa?s=264&#038;d=mm&#038;r=x 2x' class='avatar avatar-132 photo' height='132' width='132' /> </a>
</div>
<div class="author-desc-wrapper">
<a class="author-title" href="https://vrzone.com/articles/author/teamvr">TeamVR</a>
<div class="author-social">
<span class="social-icon-wrap"><a href="https://facebook.com/vrzone" target="_blank" title="Facebook"><i class="fa fa-facebook"></i></a></span>
<span class="social-icon-wrap"><a href="http://vrzone" target="_blank" title="Twitter"><i class="fa fa-twitter"></i></a></span>
</div>
<a href="http://www.vrzone.com" target="_blank" class="admin-dec">http://www.vrzone.com</a>
<div class="author-description">VR-Zone is a leading online technology news publication reporting on bleeding edge trends in PC and mobile gadgets, with in-depth reviews and commentaries.</div>
</div>
</div>
<footer class="entry-footer">
</footer>
</article>
<nav class="navigation post-navigation" role="navigation">
<h2 class="screen-reader-text">Post navigation</h2>
<div class="nav-links"><div class="nav-previous"><a href="https://vrzone.com/articles/apple-adds-options-for-16-inch-macbook-pro-mac-pro-ahead-of-wwdc-2020/142317.html" rel="prev"><span> Previous Article</span> <p>Apple Adds Options For 16-inch MacBook Pro, Mac Pro Ahead of WWDC 2020</p></a></div></div>
</nav> <div class="vmag-related-wrapper">
<h4 class="related-title">Related Articles</h4>
<div class="related-posts-wrapper clearfix"> <div class="single-post">
<div class="post-thumb">
<a href="https://vrzone.com/articles/mi-5-review-powerful-rigid/111849.html">
<img src="https://vrzone.com/wp-content/uploads/2016/08/Xiaomi-Mi-5-official-images.jpg" alt="" title="Mi 5 Review: Powerful but Rigid" />
</a>
</div>
<span class="cat-links"><a href="https://vrzone.com/articles/category/personal-technology/android" class="cat-199" rel="category tag">Android</a><a href="https://vrzone.com/articles/category/news" class="cat-24" rel="category tag">News</a><a href="https://vrzone.com/articles/category/reviews" class="cat-10" rel="category tag">Reviews</a><a href="https://vrzone.com/articles/category/personal-technology/smartphones" class="cat-213" rel="category tag">Smartphones</a></span> <h3 class="small-font"><a href="https://vrzone.com/articles/mi-5-review-powerful-rigid/111849.html">Mi 5 Review: Powerful but Rigid</a></h3>
<div class="post-meta"><span class="posted-on"> <a href="https://vrzone.com/articles/mi-5-review-powerful-rigid/111849.html" rel="bookmark"><time class="entry-date published" datetime="2016-08-03T17:17:03+08:00">August 3, 2016</time><time class="updated" datetime="2016-08-03T17:39:38+08:00">August 3, 2016</time></a></span></div>
</div>
<div class="single-post">
<div class="post-thumb">
<a href="https://vrzone.com/articles/first-confirmed-case-of-smartphone-trojan-infection-shows-up-in-japan/12272.html">
<img src="https://vrzone.com/wp-content/uploads/2013/05/phone.jpg" alt="" title="First confirmed case of smartphone trojan infection shows up in Japan" />
</a>
</div>
<span class="cat-links"><a href="https://vrzone.com/articles/category/personal-technology/android" class="cat-199" rel="category tag">Android</a><a href="https://vrzone.com/articles/category/personal-technology/ios" class="cat-269" rel="category tag">IOS</a><a href="https://vrzone.com/articles/category/news" class="cat-24" rel="category tag">News</a><a href="https://vrzone.com/articles/category/personal-technology/smartphones" class="cat-213" rel="category tag">Smartphones</a></span> <h3 class="small-font"><a href="https://vrzone.com/articles/first-confirmed-case-of-smartphone-trojan-infection-shows-up-in-japan/12272.html">First confirmed case of smartphone trojan infection shows up in Japan</a></h3>
<div class="post-meta"><span class="posted-on"> <a href="https://vrzone.com/articles/first-confirmed-case-of-smartphone-trojan-infection-shows-up-in-japan/12272.html" rel="bookmark"><time class="entry-date published updated" datetime="2011-05-19T12:25:00+08:00">May 19, 2011</time></a></span></div>
</div>
<div class="single-post">
<div class="post-thumb">
<a href="https://vrzone.com/articles/corsair-starts-making-fully-built-gaming-pcs-vr-corsair-one/121655.html">
<img src="https://vrzone.com/wp-content/uploads/2017/02/corsair-one.png" alt="" title="Corsair starts making fully-built gaming PCs for VR with Corsair One" />
</a>
</div>
<span class="cat-links"><a href="https://vrzone.com/articles/category/gaming" class="cat-106" rel="category tag">Gaming</a></span> <h3 class="small-font"><a href="https://vrzone.com/articles/corsair-starts-making-fully-built-gaming-pcs-vr-corsair-one/121655.html">Corsair starts making fully-built gaming PCs for VR with Corsair One</a></h3>
<div class="post-meta"><span class="posted-on"> <a href="https://vrzone.com/articles/corsair-starts-making-fully-built-gaming-pcs-vr-corsair-one/121655.html" rel="bookmark"><time class="entry-date published updated" datetime="2017-02-08T18:33:45+08:00">February 8, 2017</time></a></span></div>
</div>
</div> </div>
<div id="comments" class="comments-area">
<div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/articles/huawei-p40-pro-5g-review-petal-search-supercharges-the-app-xperience/142344.html#respond" style="display:none;">Cancel reply</a></small></h3> <form action="https://vrzone.com/core/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate>
<p class="comment-notes"><span id="email-notes">Your email address will not be published.</span></p><p class="comment-form-author"><label for="author">Name</label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" /></p>
<p class="comment-form-email"><label for="email">Email</label> <input id="email" name="email" type="email" value="" size="30" maxlength="100" aria-describedby="email-notes" /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="url" value="" size="30" maxlength="200" /></p>
<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /><label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p>
<p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><input type="hidden" name="_mc4wp_subscribe_wp-comment-form" value="0" /><p class="mc4wp-checkbox mc4wp-checkbox-wp-comment-form"><label><input type="checkbox" name="_mc4wp_subscribe_wp-comment-form" value="1" checked="checked" /><span>Sign me up for the newsletter!</span></label></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='142344' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="2c950765ca" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="41" /></p> </form>
</div>
<p class="akismet_comment_form_privacy_notice">This site uses Akismet to reduce spam. <a href="https://akismet.com/privacy/" target="_blank" rel="nofollow noopener">Learn how your comment data is processed</a>.</p>
</div>
</main>
</div>
<aside id="secondary" class="widget-area vmag-sidebar" role="complementary">


<section id="proper-rss-widget-2" class="widget proper-rss-widget"><div class="proper-widget proper-rss-widget"><h4 class="widget-title"><span class="title-bg">SGCafe.com</span></h4><ul class="proper-feed-links proper-links-list"><li><p><a href="https://sgcafe.com/2020/06/kin-iro-mosaic-moe-anime-movie-announces-official-title-releases-key-visual/" title="Kin-Iro Mosaic moe anime movie announces official title, releases key visual" target="_blank">Kin-Iro Mosaic moe anime movie announces official title, releases key visual</a></p><p class="proper-rss-blurb"><p><img width="352" height="500" src="https://images.sgcafe.net/2020/06/Kiniro-Thank-You-352x500.jpeg" class="attachment-medium size-medium wp-post-image" alt="" /><br />Yui Hara&#8217;s Kin-iro Mosaic moe manga is getting a brand new anime movie! And now, its official website has announced that the film&#8217;s title will be Kin-iro Mosaic Thank you!!. They also released a brand new key visual featuring Alice in an English countryside as well: Studio Gokumi is producing the anime with AXSiZ. Meanwhile,...</p>
<div class="read-more-link"><a href="https://sgcafe.com/2020/06/kin-iro-mosaic-moe-anime-movie-announces-official-title-releases-key-visual/">Read More</a></div>
<p>The post <a rel="nofollow" href="https://sgcafe.com/2020/06/kin-iro-mosaic-moe-anime-movie-announces-official-title-releases-key-visual/">Kin-Iro Mosaic moe anime movie announces official title, releases key visual</a> appeared first on <a rel="nofollow" href="https://sgcafe.com">SGCafe</a>.</p>
</p></li></ul></div></section>
<section id="adwidget_htmlwidget-17" class="widget AdWidget_HTMLWidget"><div style='text-align: center;'><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-5519572716512296" data-ad-slot="8567008605"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div></section>

<section id="text-2" class="widget widget_text"><h4 class="widget-title"><span class="title-bg">About VR-Zone</span></h4> <div class="textwidget"><iframe src="//www.facebook.com/plugins/likebox.php?href=https%3A%2F%2Fwww.facebook.com%2Fvrzone&amp;width=292&amp;height=258&amp;show_faces=true&amp;colorscheme=dark&amp;stream=false&amp;show_border=false&amp;header=false&amp;appId=189178211131816" scrolling="no" frameborder="0" style="border:none; overflow:hidden; width:100%; height:258px;" allowTransparency="true"></iframe></div>
</section>
<section id="adwidget_htmlwidget-10" class="widget AdWidget_HTMLWidget"><div style='text-align: center;'><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-5519572716512296" data-ad-slot="3852096334"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div></section> </aside>
</div>
</div>
<footer id="colophon" class="site-footer" role="contentinfo">
<div class="vmag-container">
<div class="site-info">
© 1999 - 2019 VR Zone AP Pte. Ltd. <div class="clear"></div>
</div>
<div class="footer-menu-wrapper">
<nav id="footer-site-navigation" class="footer-navigation" role="navigation">
<div class="menu-footer-container"><ul id="footer-menu" class="menu vmag_pro_mega_menu"><li id="menu-item-32057" class="menu-item menu-item-type-custom menu-item-object-custom page_item page-item-32057 no-mega-menu"><a href="http://vrmedia.com.sg/contact-us/">Contact Us</a></li>
<li id="menu-item-32056" class="menu-item menu-item-type-custom menu-item-object-custom page_item page-item-32056 no-mega-menu"><a href="https://vrzone.com/privacy_policy.php">Privacy Policy</a></li>
<li id="menu-item-32053" class="menu-item menu-item-type-custom menu-item-object-custom page_item page-item-32053 no-mega-menu"><a href="http://vrmedia.com.sg">Advertising</a></li>
<li id="menu-item-32054" class="menu-item menu-item-type-custom menu-item-object-custom page_item page-item-32054 no-mega-menu"><a href="http://vrmedia.com.sg">Jobs</a></li>
<li id="menu-item-32055" class="menu-item menu-item-type-custom menu-item-object-custom page_item page-item-32055 no-mega-menu"><a href="https://vrzone.com/our-team">Our Team</a></li>
</ul></div> </nav>
</div>
</div>
</footer>
<a href="#masthead" id="scroll-up"><i class="fa fa-sort-up"></i></a>
</div>


<script type='text/javascript'><!--//<![CDATA[
   var m3_u = (location.protocol=='https:'?'https://pikachu.vrzone.com/www/delivery/ajs.php':'http://pikachu.vrzone.com/www/delivery/ajs.php');
   var m3_r = Math.floor(Math.random()*99999999999);
   if (!document.MAX_used) document.MAX_used = ',';
   document.write ("<scr"+"ipt type='text/javascript' src='"+m3_u);
   document.write ("?zoneid=200");
   document.write ('&cb=' + m3_r);
   if (document.MAX_used != ',') document.write ("&exclude=" + document.MAX_used);
   document.write (document.charset ? '&charset='+document.charset : (document.characterSet ? '&charset='+document.characterSet : ''));
   document.write ("&loc=" + escape(window.location));
   if (document.referrer) document.write ("&referer=" + escape(document.referrer));
   if (document.context) document.write ("&context=" + escape(document.context));
   if (document.mmm_fo) document.write ("&mmm_fo=1");
   document.write ("'><\/scr"+"ipt>");
//]]>--></script><noscript><a href='http://pikachu.vrzone.com/www/delivery/ck.php?n=acb2af1f&cb=INSERT_RANDOM_NUMBER_HERE' target='_blank'><img src='http://pikachu.vrzone.com/www/delivery/avw.php?zoneid=200&cb=INSERT_RANDOM_NUMBER_HERE&n=acb2af1f' border='0' alt='' /></a></noscript>


<script type='text/javascript'><!--//<![CDATA[
   var m3_u = (location.protocol=='https:'?'https://pikachu.vrzone.com/www/delivery/ajs.php':'http://pikachu.vrzone.com/www/delivery/ajs.php');
   var m3_r = Math.floor(Math.random()*99999999999);
   if (!document.MAX_used) document.MAX_used = ',';
   document.write ("<scr"+"ipt type='text/javascript' src='"+m3_u);
   document.write ("?zoneid=250");
   document.write ('&cb=' + m3_r);
   if (document.MAX_used != ',') document.write ("&exclude=" + document.MAX_used);
   document.write (document.charset ? '&charset='+document.charset : (document.characterSet ? '&charset='+document.characterSet : ''));
   document.write ("&loc=" + escape(window.location));
   if (document.referrer) document.write ("&referer=" + escape(document.referrer));
   if (document.context) document.write ("&context=" + escape(document.context));
   if (document.mmm_fo) document.write ("&mmm_fo=1");
   document.write ("'><\/scr"+"ipt>");
//]]>--></script><noscript><a href='http://pikachu.vrzone.com/www/delivery/ck.php?n=a1492458&cb=INSERT_RANDOM_NUMBER_HERE' target='_blank'><img src='http://pikachu.vrzone.com/www/delivery/avw.php?zoneid=250&cb=INSERT_RANDOM_NUMBER_HERE&n=a1492458' border='0' alt='' /></a></noscript><script type='text/javascript'>
/* <![CDATA[ */
var wpreview = {"ajaxurl":"https:\/\/vrzone.com\/core\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://vrzone.com/wp-content/plugins/wp-review/assets/js/main.js?ver=4.0.16'></script>
<script type='text/javascript' src='https://vrzone.com/wp-content/themes/vmag-pro/assets/library/lightslider/lightslider.js?ver=1.1.5'></script>
<script type='text/javascript' src='https://vrzone.com/wp-content/themes/vmag-pro/assets/js/wow.js?ver=1.1.2'></script>
<script type='text/javascript' src='https://vrzone.com/wp-content/themes/vmag-pro/assets/js/jquery.prettyPhoto.js?ver=3.1.6'></script>
<script type='text/javascript' src='https://vrzone.com/wp-content/themes/vmag-pro/assets/js/iframe-api.js?ver=1.0.0'></script>
<script type='text/javascript' src='https://vrzone.com/wp-content/themes/vmag-pro/assets/library/scrollbar/jquery.mCustomScrollbar.min.js?ver=3.1.5'></script>
<script type='text/javascript' src='https://vrzone.com/wp-content/themes/vmag-pro/assets/library/sticky/jquery.sticky.js?ver=1.0.2'></script>
<script type='text/javascript' src='https://vrzone.com/wp-content/themes/vmag-pro/assets/library/theia-sticky-sidebar/theia-sticky-sidebar.js?ver=1.5.0'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WowOption = {"mode":"enable"};
var newsTicker = {"controls":"1"};
var vmag_pro_ajax_script = {"ajaxurl":"https:\/\/vrzone.com\/core\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://vrzone.com/wp-content/themes/vmag-pro/assets/js/vmag-custom.js?ver=1.0.13'></script>
<script type='text/javascript' src='https://vrzone.com/core/wp-includes/js/wp-embed.min.js?ver=5.1.1'></script>
<script async="async" type='text/javascript' src='https://vrzone.com/wp-content/plugins/akismet/_inc/form.js?ver=4.0.8'></script>
<div id="upprev_box"><h6>Read previous post:</h6><div class="upprev_excerpt upprev_thumbnail"><a href="https://vrzone.com/articles/apple-adds-options-for-16-inch-macbook-pro-mac-pro-ahead-of-wwdc-2020/142317.html" title="Apple Adds Options For 16-inch MacBook Pro, Mac Pro Ahead of WWDC 2020" class="upprev_thumbnail" rel="Huawei P40 Pro+ 5G Review: Petal Search Supercharges The App-xperience"><img width="48" height="36" src="https://vrzone.com/wp-content/uploads/2020/05/photo-1509227035009-4bef0b738dd3-1.jpeg" class="iworks_upprev_thumb wp-post-image" alt="" title="Apple Adds Options For 16-inch MacBook Pro, Mac Pro Ahead of WWDC 2020" srcset="https://vrzone.com/wp-content/uploads/2020/05/photo-1509227035009-4bef0b738dd3-1.jpeg 1266w, https://vrzone.com/wp-content/uploads/2020/05/photo-1509227035009-4bef0b738dd3-1-300x225.jpeg 300w, https://vrzone.com/wp-content/uploads/2020/05/photo-1509227035009-4bef0b738dd3-1-768x577.jpeg 768w, https://vrzone.com/wp-content/uploads/2020/05/photo-1509227035009-4bef0b738dd3-1-1024x769.jpeg 1024w, https://vrzone.com/wp-content/uploads/2020/05/photo-1509227035009-4bef0b738dd3-1-480x357.jpeg 480w, https://vrzone.com/wp-content/uploads/2020/05/photo-1509227035009-4bef0b738dd3-1-510x369.jpeg 510w" sizes="(max-width: 48px) 100vw, 48px" /></a><h5><a href="https://vrzone.com/articles/apple-adds-options-for-16-inch-macbook-pro-mac-pro-ahead-of-wwdc-2020/142317.html" rel="Huawei P40 Pro+ 5G Review: Petal Search Supercharges The App-xperience">Apple Adds Options For 16-inch MacBook Pro, Mac Pro Ahead of WWDC 2020</a></h5><p>16-inch MacBook Pro, Mac Pro gets updates Just weeks from the first-ever virtual WWDC 2020, Apple has announced a smattering...</p></div><a id="upprev_close" href="#" rel="close">Close</a></div></body>
</html>
